Dataset Create/Delete Failures

Incident Report for Sanity

Resolved

This incident has been resolved.
Posted Jul 04, 2025 - 16:26 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 04, 2025 - 10:13 UTC

Identified

As of June 30th, we've identified an issue with dataset deletions for some customers - datasets aren't properly being disposed of and this limits the ability to create new datasets. We're working on mitigating the issue.
Posted Jul 03, 2025 - 16:20 UTC