Elevated API error rates for some customers

Incident Report for Sanity

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 09:41 UTC

Monitoring

Error levels have returned to normal at 09:00 UTC and people should no longer experience issues. We will continue monitoring closely for some time before marking the incident as resolved.
Posted Nov 17, 2025 - 09:00 UTC

Investigating

Starting 08:45 UTC, a small subset of customers are intermittently experiencing 504 errors (gateway time-outs) using the query and mutate endpoints. We are currently investigating this issue.
Posted Nov 17, 2025 - 08:52 UTC
This incident affected: api.sanity.io and apicdn.sanity.io.