Issue with annotations in Portable Text Editor on Studio v4.8.0

Incident Report for Sanity

Resolved

We experienced a regression on v4.8.0 of the Studio affecting annotations in the Portable Text Editor. Specifically, people reported an issue where their selection in the annotation was not recorded as expected.

We have released a fix in a new version (v4.8.1) and deprecated the faulty v4.8.0 release on NPM. Apologies for any impact this issue had on your content operations.
Posted Sep 10, 2025 - 17:30 UTC