Elevated API error rates for some customers

Incident Report for Sanity

Resolved

We've implemented a fix for this issue and are no longer seeing any API failures.
Posted Jun 30, 2025 - 13:38 UTC

Monitoring

The issue has been identified and we are monitoring. A small subset of customers was affected. Those customers may have observed 524 errors for queries against the API (and potentially the API CDN, for uncached queries) between 18:25 and 18:55 UTC.
Posted Jun 27, 2025 - 21:02 UTC

Investigating

We are currently investigating failures of the Query API affecting some customers. The API CDN will also be impacted for uncached queries.
Posted Jun 27, 2025 - 19:26 UTC
This incident affected: api.sanity.io and apicdn.sanity.io.