Degraded performance and issues loading data on Manage
Incident Report for Sanity
Resolved
This incident has been resolved.
Posted Sep 29, 2023 - 15:04 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 29, 2023 - 14:59 CEST
Investigating
Starting at 10:50 UTC, we are experiencing degraded performance and issues loading data on Manage. People may be unable to see and edit their plans. Plan data and billing are not impacted. We are currently investigating this incident.

Services affected: Manage
Next update: 30 minutes
Posted Sep 29, 2023 - 14:53 CEST
This incident affected: Manage.