Elevated listener latency impacting Studio performance

Incident Report for Sanity

Resolved

The incident has been resolved. Further optimization work is planned as part of a broader effort.
Posted Sep 22, 2026 - 10:02 UTC

Monitoring

We have identified the core issue and planning to roll out a set of updates to mitigate the problem. Studio performance should not be affected anymore. We are monitoring the incident now.
Posted Sep 22, 2026 - 09:33 UTC

Update

We have had another occurrence of listener latency. We are continuing to investigate the issue.
Posted Sep 22, 2026 - 09:15 UTC

Update

The issue should not affect the performance of any Studios anymore. We are continuing to investigate the issue.
Posted Sep 22, 2026 - 09:05 UTC

Update

We are currently continuing to investigate the issue.
Posted Sep 22, 2026 - 08:45 UTC

Investigating

We are currently investigating an issue where elevated listener latency may result in slower performance and lag within Sanity Studio for a small subset of customers. Our team is actively working to identify the root cause and mitigate the impact. Issue starting around 7:40 UTC.
We’ll provide further updates as more information becomes available.
Posted Sep 22, 2026 - 08:27 UTC
This incident affected: Studio.