Elevated HTTP 429 rate-limit errors on API and API CDN

Incident Report for Sanity

Resolved

This incident has been resolved; API error rates returned to normal at 11:07 UTC after the fix was implemented.
Posted Oct 14, 2025 - 11:41 UTC

Monitoring

A fix has been implemented, and we are observing that requests have now returned to normal. We are continuing to monitor.
Posted Oct 14, 2025 - 11:15 UTC

Identified

We are addressing renewed 429 error spikes that are impacting customers globally. These errors are surfacing as rate-limit errors for queries to both the API and API CDN.
Posted Oct 14, 2025 - 11:08 UTC

Investigating

We are aware of customers experiencing HTTP 429 rate limiting on our API, and are currently investigating.
Posted Oct 14, 2025 - 11:02 UTC
This incident affected: api.sanity.io and apicdn.sanity.io.